Sverweis in einer Excel Tabelle verwenden

Опубликовал Admin
29-01-2018, 23:00
779
0
Die Verwendung von Sverweis in Microsoft Excel scheint nur von Profis leicht bewerkstelligt zu werden, es ist aber eigentlich relativ einfach. Nur durch das Lernen eines kurzen Codes kannst du deine Datenabfragen aus jeglichem Tabellenblatt erleichtern.

Sverweis verstehen

  1. Sei dir bewusst, wann man Sverweis verwendet. Sverweis ist eine Funktion in Excel, die dir erlaubt, den Wert einer Zelle zu tippen, um den Wert einer korrespondierenden Zelle in derselben Reihe aufzufinden.
    • Verwende sie, um Informationen aus großen Tabellen zu finden oder wenn du wiederholende Informationen suchen willst.
    • Stell dir vor, du bist ein Lehrer mit einer Schülerliste in Excel. Du könntest Sverweis verwenden, um den Namen eines Schülers einzutippen und sofort die Note des Schülers aus einer korrespondierenden Zelle zu erhalten.
    • Sverweis ist nützlich, wenn du im Handel arbeitest. Du kannst einen Artikelnamen suchen und die Artikelnummer oder den Preis zurückerhalten.
  2. Stell sicher, dass deine Tabelle ordnungsgemäß organisiert ist. Das „S“ in Sverweis steht für „senkrecht“. Das bedeutet, dass deine Tabelle in senkrechten Listen organisiert sein muss, da die Funktion nur in Spalten, nicht in Zeilen, sucht.
  3. Verwende Sverweis, um einen Rabatt zu finden. Wenn du Sverweis für ein Geschäft verwendest, kannst du es für eine Tabelle formatieren, um einen Preis oder Rabatt für einen Artikel zu kalkulieren.

Die Sverweis Werte verstehen

  1. Verstehe das „Suchkriterium“. Das ist die Zelle, von der aus du startest; der Ort, an dem du den Sverweis Code eintippst.
    • Das ist eine Zellenbezeichnung wie F3. Sie bezieht sich auf den Ort deiner Suche.
    • Du wirst dort deinen Sverweis Code eingeben. Was immer du hier suchst, es muss aus der ersten Spalte deiner Tabelle sein.
    • Es ist nützlich, das mit ein wenig Abstand zum Rest deiner fertigen Tabelle zu platzieren, damit du es nicht mit deinen anderen Daten vermischt.
  2. Verstehe die „Tabellenmatrix“. Dies sind die Zellnummern des kompletten Datenbereichs.
    • Die erste Zahl ist links oben in deiner Tabelle und die zweite Zahl ist die untere rechte Ecke deiner Daten.
    • Wenn wir das Beispiel des Lehrers mit einer Klassenliste verwenden, stell dir vor, dass du zwei Spalten hast. In der ersten sind die Namen aller Schüler und in der zweiten ist ihre Note. Wenn du 30 Schüler hast, die in A2 beginnen, dann besteht die erste Spalte von A2-A31 aus Datensätzen. Die zweite Spalte mit den Noten geht von B2-B31. Daher geht die Datenmatrix von A2:B31.
    • Sei vorsichtig, dass du die Tabellenüberschriften nicht mit einschließt. Das bedeutet, dass du den Namen jeder Spalte – wie „Schülername“ und „Note“ nicht in deiner Datenmatrix einschließt. Wahrscheinlich wäre das A1 und B1 in deiner Tabelle.
  3. Suche die „Spaltenindexnummer“. Das ist die Zahl der Reihe, in der du Daten suchst.
    • Damit Sverweis funktioniert, musst du die Zahl der Spalte, nicht den Namen, verwenden. Wenn du also nach den Noten deiner Schüler suchst, musst du „2“ als Spaltenindexnummer verwenden, da die Noten in der zweiten Spalte stehen.
    • Verwende dafür nicht den Buchstaben, sondern nur die Zahl, welche die Spalte repräsentiert. Sverweis wird „B“ nicht als korrekte Spalte erkennen, nur „2“.
    • Du musst also buchstäblich die Anzahl von Spalten nach rechts zählen, um die Spaltenindexnummer zu finden, wenn du mit einer sehr großen Tabelle arbeitest.
  4. Verstehe den „Bereich Verweis“. Das ist der Teil der Sverweis Funktion, der wissen will, ob du eine exakte Zahl oder eine ungefähre willst.
    • Wenn du eine genaue Zahl willst und keine, die gerundet oder von einer nebenliegenden Zelle ist, dann musst du „FALSCH“ in deiner Sverweis Funktion wählen.
    • Wenn du eine geschätzte Zahl, die gerundet ist oder von einer benachbarten Zelle, dann kannst du „WAHR“ dort eingeben.
    • Wenn du nicht sicher bist, was du brauchst, ist es normalerweise besser, „FALSCH“ zu nehmen, damit du eine genaue Antwort betreffend deiner Suche in der Tabelle erhältst.

Sverweis verwenden

  1. Erstelle dein Tabellenblatt. Du musst zumindest zwei Spalten mit Informationen haben, damit Sverweis funktioniert, du kannst aber so viele haben wie du brauchst.
  2. Tippe in einer leeren Zelle die Sverweis Formel ein. Gib diese Formel in der Zelle ein: =Sverweis (Suchkriterium, Matrix, Spaltenindex, Bereich_Verweis).
    • Du kannst jegliche Zelle verwenden, um das einzutippen, vergiss jedoch nicht, dass jene Zelle, die du wählst, als das „Suchkriterium“ in deinem Funktionscode eingegeben wird.
    • Lies im Ratgeber oben nach, wenn du Informationen darüber willst, was jeder dieser Werte sein soll. Wenn wir das Beispiel unserer Schülerliste mit den vorher genannten Werten wieder aufgreifen, dann schaut unsere Sverweis Formel wie folgt aus: =SVERWEIS(F3,A2:B32,2,FALSCH)
  3. Erweitere die Sverweis Funktion, um andere Zellen einzuschließen. Wähle die Zelle mit deinem Sverweis Code. Wähle in der unteren rechten Ecke den „Zellengriff“ und ziehe ihn, um eine oder mehrere andere Zellen einzuschließen.
    • Das erlaubt dir, mithilfe von Sverweis zu suchen, weil du mindestens zwei Zellen haben musst, um einen Input und einen Output von Informationen zu haben.
    • Du kannst den Zweck jeder Zelle in einer benachbarten (aber nicht verbundenen) Zelle eingeben. Beispielsweise kannst du links von der Zelle, in der du nach einem Schüler suchst, „Schülername“ eingeben.
  4. Prüfe Sverweis. Um das zu tun, gib den Suchwert ein – in unserem Beispiel wäre das der Name eines Schülers, den du in deinem Sverweis Code mit eingeschlossen hast. Dann sollte dir Sverweis automatisch die Note des entsprechenden Schülers in der danebenliegenden Zelle auswerfen.

Tipps

  • Um zu vermeiden, dass sich der Zellwert in deinem Sverweis Code verändert, wenn du Zellen in deiner Tabelle hinzufügst oder bearbeitest, stell in deiner Tabellenmatrix ein „$“ Zeichen vor jeden Buchstaben/jeder Zahl. Unser Sverweis Code wäre dadurch beispielsweise =SVERWEIS(F3;$A$2:$B$32,2,FALSCH)
  • Stell sicher, dass du keine vor- oder nachgestellten Leerzeichen oder inkonsistente Anführungszeichen in deiner Tabelle verwendest.
Теги:
Information
Users of Guests are not allowed to comment this publication.