Como Usar a Função PROCV no Excel

Опубликовал Admin
29-01-2018, 23:00
544
0
Usar a função Procv no Microsoft Excel pode parecer como uma tarefa facilmente alcançada apenas por profissionais, mas na verdade é uma coisa simples de se fazer. Apenas aprendendo este pequeno trecho de código, você pode simplificar a recuperação de informações de qualquer planilha.

Entendendo Procv

  1. Saiba quando usar Procv. Procv é uma função no Excel que permite que você digite o valor de uma célula para procurar o valor em uma célula correspondente na mesma linha.
    • Use para procurar informações em uma planilha extensa, ou se você tiver informações repetitivas.
    • Imagine ser um professor com uma lista de estudantes no Excel. Você pode usar Procv para digitar o nome do estudante e receber imediatamente a nota dele na célula correspondente.
    • Procv é útil se você trabalhar com produtos. Você pode pesquisar o nome de um item e receber o número do item ou seu preço.
  2. Certifique-se de que sua planilha esteja organizada corretamente. O "v" no Procv significa "vertical". Isso significa que sua planilha deve estar organizada em listas verticais, já que a função irá procurar apenas em colunas, não em linhas.
  3. Use Procv para encontrar um desconto. Se você estiver usando Procv em uma empresa, você pode formatá-lo para uma tabela para calcular um preço ou desconto de um item.

Entendendo os Valores do Procv

  1. Entenda o "valor procurado". Esta é a célula onde você vai começar; o lugar onde você irá inserir o código do Procv.
    • Ele é o número de uma célula, como por exemplo a célula F3. Ele se refere ao local da busca.
    • Você irá inserir o código Procv aqui. Qualquer que seja a busca que você fizer aqui deve ser à partir da primeira coluna da planilha.
    • É interessante colocar o código alguns espaços de distância da sua planilha completa, para que você não misture com outros dados.
  2. Entenda "matriz tabela". Estes são só números de célula do intervalo completo de dados.
    • O primeiro número será aquele na parte superior esquerda da sua planilha e o segundo número estará na parte inferior direita dos seus dados.
    • Usando o exemplo do professor com uma lista de alunos, imagine que você tem duas colunas. A primeira tem os nomes de todos os alunos, a segunda tem a média. Se você tem 30 estudantes começando na A3, então a primeira coluna lista os valores de A2-A31. A segunda coluna com notas vai de B2-B31. Portanto, a matriz tabela é A2:B31.
    • Tome cuidado para não incluir os cabeçalhos da tabela. Isso significa que você não inclui o nome de cada coluna, como "nomes dos estudantes" e "média" na sua matriz tabela. Estas células são provavelmente a A1 e a B2 na sua planilha.
  3. Encontre o "número de índice da coluna". Este é o número da linha que você está pesquisando os dados.
    • Para o procv funcionar, você deve usar o número da coluna, não o nome. Então mesmo que você esteja procurando pelas notas dos alunos, você colocaria "2" como número de índice da coluna, porque a nota está listada na segunda coluna.
    • Não use a letra para isso, apenas o número representando a coluna. Procv não irá reconhecer "B" como coluna correta, apenas "2".
    • Você talvez precise contar literalmente o número de colunas à direita para encontrar o número de índice da coluna se você estiver trabalhando com uma planilha muito extensa.
  4. Entenda "procurar intervalo". Esta é a parte do código do procv que quer saber se você quer um número exato ou estimado.
    • Se você quiser um número exato, não um que seja arredondado ou de uma célula vizinha, você deve colocar "Falso" na função procv.
    • Se você quiser um número estimado que seja arredondado, ou emprestado de uma célula vizinha, então você pode por "Verdadeiro".
    • Se você não tem certeza de qual você precisa, é tipicamente seguro colocar "Falso" para que você tenha a resposta exata à sua busca na planilha.

Usando o Procv

  1. Crie sua célula. Você deve ter pelo menos 2 colunas de informação para que Procv funcione, mas você pode ter quantas quiser.
  2. Em uma célula em branco digite a fórmula Procv. Na célula, insira esta fórmula: PROCV(valor_procurado; matriz_tabela; núm_índice_coluna; procurar_intervalo).
    • Você pode usar qualquer célula para colocar a fórmula, mas lembre que a célula que você usar será inserida como o "valor procurado" no código da função.
    • Consulte o guia acima para informações sobre o que cada um destes valores deve ser. Seguindo o nosso mesmo exemplo de uma lista de alunos usando os valores mencionados anteriormente, nossa fórmula Procv deve parecer com esta: =PROCV(F3,A2:B32,2,FALSO)
  3. Expanda a função Procv para incluir outras células. Escolha a célula com seu código Procv. Na parte inferior direita, selecione o marcador da célula e arrasta para incluir uma ou mais células.
    • Isso permite que você pesquise usando Procv, porque você precisa ter pelo menos duas células para poder ter uma informação de entrada/saída.
    • Você pode colocar o propósito em cada célula em uma célula adjacente (mas não mesclada). Por exemplo, à esquerda da caixa onde você procura por um aluno, você pode colocar "Nomes dos Alunos".
  4. Teste Procv. Para fazer isso insira o valor procurado, em nosso exemplo seria o nome do aluno, em uma das células onde você incluiu o código Procv. Então, o Procv deve fornecer a você automaticamente a nota do dito estudante na célula adjacente.

Dicas

  • Para impedir que o valor da célula mude em seu código Procv quando você adicionar, ou simplesmente ajustar as células em sua tabela, ponha um '$' antes de cada letra/número em sua matriz tabela. Por exemplo, nosso código Procv seria modificado para =PROCV(F3,$A$2:$B$32,2,FALSO)
  • Certifique-se de que você não tem nenhum espaço ou aspas inconsistentes na sua planilha.
Теги:
Information
Users of Guests are not allowed to comment this publication.